Back to overview
Degraded

Degraded dashboard in the UK

Feb 13 at 12:26am UTC
Affected services
Better Stack

Resolved
Feb 13 at 02:53am UTC

Bunny CDN resolved the issue. We apologize for the inconvenience.

Created
Feb 13 at 12:26am UTC

Bunny CDN, one of our CDN providers, is experiencing a software bug on their UK-located PoP. We're in touch with them and the issue should be resolved within a few minutes. We apologize for the inconvenience. If you urgently need to use the dashboard, please, use a VPN to connect to any US location. Thank you.