Back to overview
Resolved

Degraded Telemetry performance

Aug 20, 2026 at 2:39pm UTC
Affected services
Telemetry

Resolved
Aug 20, 2026 at 2:48pm UTC

The issue was resolved, we apologize for the incovenience, please let us know if we can help with anything at hello@betterstack.com.

Created
Aug 20, 2026 at 2:39pm UTC

Telemetry dashboard might be unavailable for some customers due to a database issue, we're investigating.