Back to overview
Degraded
Degraded dashboard & API performance
Feb 16 at 03:36pm UTC
Affected services
Uptime backend processing health
Resolved
Feb 16 at 03:43pm UTC
The database latency is now back to normal. We apologize for the inconvenience. Need help? Please let us know at hello@betterstack.com.
Affected services
Uptime backend processing health
Created
Feb 16 at 03:36pm UTC
Dashboard & API performance has been reported as degraded in some regions due to increased database latency. We're investigating the issue and are sorry for the inconvenience.
Affected services
Uptime backend processing health