Degraded Uptime backend processing
Resolved
Dec 04 at 03:55pm UTC
Everything should be back to normal. We sincerely apologize for the inconvenience! Please let us know at hello@betterstack.com if you need any help.
Affected services
Uptime backend processing health
Public status pages
Updated
Dec 04 at 03:05pm UTC
Status pages performance is back to normal.
Affected services
Public status pages
Updated
Dec 04 at 02:42pm UTC
Customers accessing status pages may experience longer loading times or unavailability from certain regions.
Affected services
Public status pages
Created
Dec 04 at 02:20pm UTC
Some customers may experience delayed check processing.
We're finalizing the configuration of our infrastructure ahead of tonight's maintenance and unfortunately experiencing degraded performance in one of our clusters.
Everything should be back to normal shortly. Sincere apologies for the inconvenience.
Affected services
Uptime backend processing health