Back to overview
Degraded
Degraded dashboard & API performance
Dec 05 at 09:34am UTC
Affected services
Uptime
Public status pages
Telemetry
Resolved
Dec 05 at 11:52am UTC
All services are back to normal again. Sincere apologies for the inconvenience.
Please reach out to hello@betterstack.com if you have any questions or need help.
Affected services
Uptime
Public status pages
Telemetry
Updated
Dec 05 at 10:28am UTC
Telemetry dashboards are back up and running.
Affected services
Uptime
Public status pages
Telemetry
Created
Dec 05 at 09:34am UTC
We're experiencing service degradation related to today's completed maintenance required by our cloud hosting provider. Our engineers are working hard to ensure everything is running smoothly as soon as possible.
Affected services
Uptime
Public status pages
Telemetry