Back to overview
Degraded
Degraded Uptime and status pages performance
Jan 09 at 12:04pm UTC
Affected services
Uptime backend processing health
Public status pages
Resolved
Jan 09 at 12:31pm UTC
All services are back to normal. Sincere apologies for the inconvenience! Please message us at hello@betterstack.com if we can help.
Affected services
Uptime backend processing health
Public status pages
Created
Jan 09 at 12:04pm UTC
Uptime and status page performance is degraded in some regions. Our engineers are looking into it.
Affected services
Uptime backend processing health
Public status pages