Back to overview
Degraded

Phone call alerts are delayed

Mar 07 at 06:10am UTC
Affected services
Uptime backend processing health

Resolved
Mar 07 at 08:28am UTC

All alerts should now work again for all customers. We apologize for the inconvenience and will re-evaluate our primary voice call provider going forward. Have questions? Please let us know at hello@betterstack.com.

Created
Mar 07 at 06:10am UTC

Some customers might not be receiving phone call alerts due to an incident with our voice provider. We have all hands on deck. Please let us know at hello@betterstack.com if we can help.