Back to overview
Degraded

Degraded Uptime dashboard and status pages

Apr 20 at 08:29pm UTC
Affected services
Uptime
Public status pages

Resolved
Apr 20 at 08:41pm UTC

All services are back to normal. Sincere apologies for the inconvenience! Please message us at hello@betterstack.com if we can help with anything.

Created
Apr 20 at 08:29pm UTC

Uptime and status page performance is degraded in some regions. Our engineers are looking into it. We apologize for the inconvenience