Back to overview
Degraded

Degraded Uptime and live tail performance

May 06 at 02:34pm UTC
Affected services
Uptime
Telemetry

Resolved
May 06 at 02:48pm UTC

All services are back to normal. Sincere apologies for the inconvenience! Please message us at hello@betterstack.com if we can help with anything.

Created
May 06 at 02:34pm UTC

We're seeing degraded performance for the Uptime dashboard and Live tail loading times in some regions. Our engineers are looking into it. We apologize for the inconvenience.