Back to overview
Degraded
Degraded Telemetry queries performance
May 16 at 09:33am UTC
Affected services
Telemetry
Resolved
May 16 at 12:10pm UTC
We’ve identified and resolved the root cause of the issue.
Log ingestion delays are cleared and query performance has returned to normal. Should you continue to experience any problems, please reach out to us at hello@betterstack.com
.
Thank you for your patience!
Affected services
Telemetry
Created
May 16 at 09:33am UTC
We’re aware of reports of intermittent delays in log ingestion and slower-than-normal query performance affecting some customers.
Our engineering team is actively investigating the root cause and working to restore full performance as soon as possible. We’ll post another update once we have more details—thank you for your patience!
Affected services
Telemetry