Back to overview
Degraded

Degraded Telemetry Performance

May 27 at 08:05am UTC
Affected services
Telemetry

Resolved
May 27 at 10:30am UTC

This issue has been resolved. Log ingestion and query performance have returned to normal.

Thank you for your patience while we worked to address this incident. If you continue to experience any issues, please don’t hesitate to reach out at "hello@betterstack.com".

Created
May 27 at 08:05am UTC

We’re currently investigating reports of sporadic log ingestion delays and reduced query performance impacting a subset of sources.

Our engineering team is working diligently to identify the cause and return systems to normal speed as quickly as possible. We’ll share another update as soon as we have more information—thank you for bearing with us!