Back to overview
Degraded

Delayed email notifications due to AWS outage

Oct 20 at 07:31am UTC
Affected services
Uptime
Telemetry

Resolved
Oct 20 at 09:29am UTC

Email deliveries are back to normal.

Created
Oct 20 at 07:31am UTC

We are seeing elevated error rates in our email delivery service due to an ongoing AWS outage. As a result, some notification emails may be delayed.

Uptime monitoring and data processing are fully operational.