Reviewing SSL behavior affecting a subset of status pages
Resolved
Nov 16 at 07:10pm UTC
We’ve resolved an issue that caused some custom status pages to fail to load or return timeout errors. The problem was related to certificate handling workflow, which temporarily prevented certain pages from obtaining or refreshing their SSL certificates.
All affected pages are now loading normally again. Thank you very much for your patience and understanding.
Please let us know at hello@betterstack.com if you'd have any further questions.
Affected services
Updated
Nov 16 at 02:45pm UTC
Following the earlier timeout issue, we’re seeing that a small subset of custom status pages did not fully recover after the initial fix at 2:15 PM UTC. Some of these pages are now encountering SSL-related errors, such as certificate validation failures or timeouts, due to an internal component not behaving correctly after the earlier disruption.
We’re continuing to investigate and will share more updates as soon as we have them.
Affected services
Updated
Nov 16 at 02:15pm UTC
The timeout issues are now resolved. We apply mitigations around 2:15 PM UTC, and affected status pages begin responding normally again.
Thanks a lot for your patience while we work through this.
Affected services
Created
Nov 16 at 01:55pm UTC
We’re currently seeing intermittent timeout issues affecting some custom status pages. The first errors begin appearing around 1:55 PM UTC, with certain requests returning no response across multiple regions.
We’re looking into this now and will share another update shortly.
Affected services