Better Stack UI is temporarily inaccessible
Resolved
Nov 18 at 12:30pm UTC
Cloudflare has mostly resolved the underlying routing issues related to their global outage, and their systems are now operating normally. With their network stabilized, the Better Stack UI and all related services are fully accessible again.
Everything on our side is now running as expected, and we are no longer seeing elevated error rates or degraded performance.
We’ll continue to monitor the situation, but no further impact is expected.
If you have any questions or notice anything unusual, please feel free to reach out to us at hello@betterstack.com
— we’re happy to help.
Thank you for your patience throughout the incident. 🙏
Affected services
Updated
Nov 18 at 12:15pm UTC
The Better Stack UI is now mostly accessible again, and many users should be able to load the dashboard normally.
Cloudflare’s global outage is still ongoing, and while their network has become more stable, intermittent routing issues may continue. This means you may still see occasional slow loading or elevated error rates as the situation fully recovers.
We’re continuing to monitor the upstream incident and will share further updates as Cloudflare stabilizes their systems.
Affected services
Created
Nov 18 at 11:35am UTC
We’re currently experiencing an issue where the Better Stack UI is temporarily inaccessible.
Our backend services, monitoring infrastructure, APIs, and alerting are fully operational — however, Cloudflare is undergoing a global outage that is impacting routing and preventing our dashboard from loading.
You can track the upstream incident here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
We’re actively monitoring the situation and will restore full access as soon as Cloudflare resolves their routing issues.
All core functionality — checks, heartbeats, alerts, log ingestion, and metrics — continues to function normally in the background.
Thank you for your patience. 🙏
Affected services