Back to overview
Degraded
Some of the status pages are under DDoS
May 8, 2026 at 7:24pm UTC
Affected services
Uptime
Resolved
May 8, 2026 at 8:05pm UTC
The attack has been successfully mitigated by our DDoS protection. Sincere apologies for the inconvenience. Need help? Let us know at hello@betterstack.com.
Affected services
Created
May 8, 2026 at 7:24pm UTC
We're mitigating. Need help? Let us know at hello@betterstack.com
Affected services