Back to overview
Degraded
Elevated Telemetry querying errors
Jun 14, 2026 at 10:49am UTC
Affected services
Telemetry
Resolved
Jun 14, 2026 at 11:40am UTC
The infrastructure issue has been resolved.
Affected services
Created
Jun 14, 2026 at 10:49am UTC
We're currently experiencing an infrastructure issue that is impacting some customer queries in our Europe region.
Affected services