Back to overview
Degraded

AWS Direct Connect connection outage

Jun 15, 2026 at 10:25am UTC
Affected services
Telemetry

Resolved
Jun 15, 2026 at 12:25pm UTC

The network issue causing this problem has been resolved.

Created
Jun 15, 2026 at 10:25am UTC

We are currently experiencing an outage in our AWS Direct Connect forwarding infrastructure; this may introduce delays or failures to ingest data.